Access Control Bypass Affecting drupal/core Open this link in a new tab package, versions >=9.3.0, <9.3.12


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-DRUPALCORE-2803581

  • published

    27 Apr 2022

  • disclosed

    26 Apr 2022

  • credit

    Kristiaan Van den Eynde

Introduced: 26 Apr 2022

New CWE-284 Open this link in a new tab
First added by Snyk

How to fix?

Upgrade drupal/core to version 9.3.12 or higher.

Overview

drupal/core is an an open source content management platform powering millions of websites and applications.

Affected versions of this package are vulnerable to Access Control Bypass via a generic entity access API which was not completely integrated with existing permissions, resulting in some possible access bypass for users who have access to use revisions of content generally, but who do not have access to individual items of node and media content.