Information Exposure Affecting drupal/core package, versions <9.3.19 >=9.4.0, <9.4.3


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-DRUPALCORE-2960163

  • published

    26 Jul 2022

  • disclosed

    26 Jul 2022

  • credit

    Guy Elsmore-Paddock and Conrad Lara

How to fix?

Upgrade drupal/core to version 9.3.19, 9.4.3 or higher.

Overview

drupal/core is an an open source content management platform powering millions of websites and applications.

Affected versions of this package are vulnerable to Information Exposure where the Image module does not correctly check access to image files that are not stored in the standard public files directory when generating derivative images using the image styles system.