Arbitrary Code Execution Affecting drupal/core package, versions <9.3.19 >=9.4.0, <9.4.3


0.0
high
  • Attack Complexity

    Low

  • Privileges Required

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-DRUPALCORE-2960164

  • published

    26 Jul 2022

  • disclosed

    26 Jul 2022

  • credit

    Elar Lang

How to fix?

Upgrade drupal/core to version 9.3.19, 9.4.3 or higher.

Overview

drupal/core is an an open source content management platform powering millions of websites and applications.

Affected versions of this package are vulnerable to Arbitrary Code Execution if the site is configured to allow the upload of files with an htaccess extension that will not be properly sanitized. This allows a bypass of the default protections.