Server-Side Request Forgery (SSRF) Affecting foodcoopshop/foodcoopshop package, versions <3.6.1


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.45% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-FOODCOOPSHOPFOODCOOPSHOP-6044734
  • published3 Nov 2023
  • disclosed2 Nov 2023
  • creditasesidaa

Introduced: 2 Nov 2023

CVE-2023-46725  (opens in a new tab)
CWE-918  (opens in a new tab)

How to fix?

Upgrade foodcoopshop/foodcoopshop to version 3.6.1 or higher.

Overview

Affected versions of this package are vulnerable to Server-Side Request Forgery (SSRF) in the Network module. An attacker can use the server as a proxy into the internal network where the server is by exploiting the /api/updateProducts.json endpoint.

Note: The checks on a valid image are not adequate, leading to a time of check time of use issue.

CVSS Base Scores

version 3.1