Exposed Dangerous Method or Function Affecting getgrav/grav package, versions >=2.0.15, <2.2.13


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.35% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-GETGRAVGRAV-21717123
  • published26 Oct 2026
  • disclosed24 Oct 2026
  • creditsoquip

Introduced: 24 Oct 2026

NewCVE-2026-116019  (opens in a new tab)
CWE-749  (opens in a new tab)

How to fix?

Upgrade getgrav/grav to version 2.2.13 or higher.

Overview

getgrav/grav is a Modern, Crazy Fast, Ridiculously Easy and Amazingly Powerful Flat-File CMS.

Affected versions of this package are vulnerable to Exposed Dangerous Method or Function via the extend() method in Blueprint.php, where untrusted Flex form override fields can exploit merge operations that rename or renumber field keys. When deepMerge() processes replace-name@ or unset-name@ directives, it relocates a field - along with any embedded data-*@ directives - to a top-level key that dynamicPathsOf() never enumerates, causing init() to fall back to the blueprint's own file trust for that key and bypass the allowlist. An authenticated attacker can supply a manipulated form override to escalate privileges or achieve remote code execution.

CVSS Base Scores

version 4.0
version 3.1