Information Exposure Affecting getgrav/grav package, versions >=2.0.0, <2.2.5


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.22% (12th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-GETGRAVGRAV-21717125
  • published26 Oct 2026
  • disclosed22 Oct 2026
  • creditbaeseungwon1010

Introduced: 22 Oct 2026

NewCVE-2026-114657  (opens in a new tab)
CWE-209  (opens in a new tab)

How to fix?

Upgrade getgrav/grav to version 2.2.5 or higher.

Overview

getgrav/grav is a Modern, Crazy Fast, Ridiculously Easy and Amazingly Powerful Flat-File CMS.

Affected versions of this package are vulnerable to Information Exposure via the Uri class in system/src/Grav/Common/Uri.php, which populates the user and password properties from the request's HTTP Basic Authentication credentials (PHP_AUTH_USER and PHP_AUTH_PW). Because these properties are subsequently rendered into the page through toArray(), __toString(), and addNonce(), an authenticated attacker can cause the victim's HTTP Basic credentials to be disclosed in page output, which a network observer or malicious script can then capture.

References

CVSS Base Scores

version 4.0
version 3.1