Information Exposure Affecting getgrav/grav package, versions >=2.0.0, <2.2.2


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.62% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-GETGRAVGRAV-21717126
  • published26 Oct 2026
  • disclosed19 Oct 2026
  • creditmanus-use, Hama1cco

Introduced: 19 Oct 2026

NewCVE-2026-112781  (opens in a new tab)
CWE-209  (opens in a new tab)

How to fix?

Upgrade getgrav/grav to version 2.2.2 or higher.

Overview

getgrav/grav is a Modern, Crazy Fast, Ridiculously Easy and Amazingly Powerful Flat-File CMS.

Affected versions of this package are vulnerable to Information Exposure via the Blueprint::extend() method in Blueprint.php, where an untrusted (page-authored) blueprint can use a replace-name@ subtree-relocating merge action to move a data-*@ directive to a key that the per-directive provenance tracking in dynamicPathsOf() never enumerates. When the directive is relocated, init() falls back to the file-level trust of the base blueprint and skips the dynamic-callable allowlist, allowing an attacker to read arbitrary configuration values from Grav::instance()['config'] that would otherwise be restricted.

References

CVSS Base Scores

version 4.0
version 3.1