Improper Handling of Highly Compressed Data (Data Amplification) Affecting getgrav/grav package, versions <2.1.7


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.32% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-GETGRAVGRAV-21717129
  • published26 Oct 2026
  • disclosed12 Oct 2026
  • creditUnknown

Introduced: 12 Oct 2026

NewCVE-2026-109324  (opens in a new tab)
CWE-409  (opens in a new tab)

How to fix?

Upgrade getgrav/grav to version 2.1.7 or higher.

Overview

getgrav/grav is a Modern, Crazy Fast, Ridiculously Easy and Amazingly Powerful Flat-File CMS.

Affected versions of this package are vulnerable to Improper Handling of Highly Compressed Data (Data Amplification) via the image transformation process. An attacker can exhaust system memory by uploading compressed oversized raster images and referencing a transform so that image processing libraries decode the full source without dimension checks, allowing repeated requests to cause service unavailability.

References

CVSS Base Scores

version 4.0
version 3.1