Information Exposure Affecting getgrav/grav package, versions >=2.0.22, <2.1.7


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.3% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-GETGRAVGRAV-21717130
  • published26 Oct 2026
  • disclosed12 Oct 2026
  • creditUnknown

Introduced: 12 Oct 2026

NewCVE-2026-109315  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade getgrav/grav to version 2.1.7 or higher.

Overview

getgrav/grav is a Modern, Crazy Fast, Ridiculously Easy and Amazingly Powerful Flat-File CMS.

Affected versions of this package are vulnerable to Information Exposure via the omission of system.debugger.token from the sandbox redaction list. An attacker can access sensitive debugger tokens by rendering them through editor-authored Twig templates and then supplying the token as X-Clockwork-Auth to retrieve profiler records containing configuration, request metadata, and database queries.

References

CVSS Base Scores

version 4.0
version 3.1