Incorrect Authorization Affecting glpi/glpi package, versions >=10.0.0, <10.0.6


Severity

0.0
high
0
10

    Threat Intelligence

    EPSS
    0.14% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-GLPIGLPI-3250301
  • published 27 Jan 2023
  • disclosed 27 Jan 2023
  • credit Cédric Anne

How to fix?

Upgrade glpi/glpi to version 10.0.6 or higher.

Overview

glpi/glpi is a free Asset and IT Management Software package with ITIL Service Desk, licenses tracking and software auditing.

Affected versions of this package are vulnerable to Incorrect Authorization in front/document.send.php that allows anonymous access to inventory files.

Workaround

This vulnerability can be avoided by disabling the native inventory and deleting inventory files from server (by default, files/_inventory).

References

CVSS Scores

version 3.1
Expand this section

Snyk

7.5 high
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    None
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    High
  • Integrity (I)
    None
  • Availability (A)
    None
Expand this section

NVD

7.5 high