Information Exposure Affecting guzzlehttp/guzzle package, versions <6.5.6 >=7.0.0, <7.4.3



    Attack Complexity High
    User Interaction Required
    Scope Changed
    Confidentiality High
    Integrity High

    Threat Intelligence

    EPSS 0.08% (33rd percentile)
Expand this section
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • published 26 May 2022
  • disclosed 25 May 2022
  • credit Unknown

How to fix?

Upgrade guzzlehttp/guzzle to version 6.5.6, 7.4.3 or higher.


Affected versions of this package are vulnerable to Information Exposure. Previous version of Guzzle contain a vulnerability with the cookie middleware. The vulnerability is that it is not checked if the cookie domain equals the domain of the server which sets the cookie via the Set-Cookie header, allowing a malicious server to set cookies for unrelated domains. For example an attacker at might set a session cookie for, logging the Guzzle client into their account and retrieving private API requests from the security log of their account.

Note that cookie middleware is disabled by default, so most library consumers will not be affected by this issue. Only those who manually add the cookie middleware to the handler stack or construct the client with ['cookies' => true] are affected. Moreover, those who do not use the same Guzzle client to call multiple domains and have disabled redirect forwarding are not affected by this vulnerability.