Improper Preservation of Permissions Affecting ibexa/core Open this link in a new tab package, versions >=4.0.0, <4.0.5 >=4.1.0, <4.1.2


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-IBEXACORE-2806343

  • published

    1 May 2022

  • disclosed

    29 Apr 2022

  • credit

    Patrick Allaert

Introduced: 29 Apr 2022

New CWE-281 Open this link in a new tab

How to fix?

Upgrade ibexa/core to version 4.0.5, 4.1.2 or higher.

Overview

Affected versions of this package are vulnerable to Improper Preservation of Permissions where object state limitation were ineffective. They would grant access to the given content regardless of the object state.