Improper Authentication Affecting laravel/framework package, versions <12.68.0>=13.0.0, <13.27.0


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.78% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Improper Authentication vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-PHP-LARAVELFRAMEWORK-21707481
  • published25 Oct 2026
  • disclosed22 Oct 2026
  • creditHristijan Manasijev

Introduced: 22 Oct 2026

NewCVE-2026-114509  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade laravel/framework to version 12.68.0, 13.27.0 or higher.

Overview

laravel/framework is a PHP framework for web artisans.

Affected versions of this package are vulnerable to Improper Authentication via TokenGuard in src/Illuminate/Auth/TokenGuard.php, where the token retrieved from the request is not validated to be a string before being used for credential lookup. An attacker can supply a non-string value (such as an array) as the API token input, causing the empty check to pass and allowing authentication as an arbitrary existing user without knowledge of their valid API token.

Note: This is only exploitable when the application is configured with a standard token-based API guard using Laravel's built-in TokenGuard.

CVSS Base Scores

version 4.0
version 3.1