Improper Password Reset Constraints Affecting laravel/framework package, versions >=5.4.0, <5.4.22 >=5.3.0, <=5.3.31


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Scope Changed
Expand this section
NVD
6.1 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-LARAVELFRAMEWORK-72117
  • published 3 Apr 2018
  • disclosed 29 May 2017
  • credit Unknown

How to fix?

Upgrade laravel/framework to version 5.4.22 or higher.

Overview

laravel/framework is a web application framework.

Affected versions of this package are vulnerable to Improper Password Reset Constraints. It does not properly constrain the host portion of a password-reset URL, which makes it easier for remote attackers to conduct phishing attacks by specifying an attacker-controlled host.