SQL Injection Affecting librenms/librenms package, versions <21.1.0


0.0
high

Snyk CVSS

    Attack Complexity High
    Confidentiality High

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.31% (70th percentile)
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-LIBRENMSLIBRENMS-1070552
  • published 8 Feb 2021
  • disclosed 8 Feb 2021
  • credit Unknown

How to fix?

Upgrade librenms/librenms to version 21.1.0 or higher.

Overview

librenms/librenms is a fully featured network monitoring system that provides a wealth of features and device support.

Affected versions of this package are vulnerable to SQL Injection in Widgets/TopDevicesController.php (aka the Top Devices dashboard widget). It allows remote authenticated attackers to execute arbitrary SQL commands via the sort_order parameter against the /ajax/form/widget-settings endpoint.