Command Injection Affecting librenms/librenms package, versions >=1.46


0.0
high

Snyk CVSS

    Attack Complexity High
    Scope Changed
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    Exploit Maturity Mature
    EPSS 96.63% (100th percentile)
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-LIBRENMSLIBRENMS-174522
  • published 25 Apr 2019
  • disclosed 24 Apr 2019
  • credit Askar

How to fix?

There is no fixed version for librenms/librenms.

Overview

librenms/librenms is a fully featured network monitoring system that provides a wealth of features and device support.

Affected versions of this package are vulnerable to Command Injection. Attackers can execute arbitrary OS commands by making a request to the html/pages/addhost.inc.php using the $_POST['community'] parameter during creation of a new device, and then making a request to /ajax_output.php?id=capture&format=text&type=snmpwalk&hostname=localhost web page that will trigger html/includes/output/capture.inc.php command mishandling, resulting in executing of OS commands.