Improper Authorization Affecting librenms/librenms package, versions >=0.0.0


0.0
high

Snyk CVSS

    Attack Complexity Low
    Integrity High

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.06% (24th percentile)
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-LIBRENMSLIBRENMS-2401225
  • published 15 Feb 2022
  • disclosed 15 Feb 2022
  • credit Faisal Fs

How to fix?

A fix was pushed into the master branch but not yet published.

Overview

librenms/librenms is a fully featured network monitoring system that provides a wealth of features and device support.

Affected versions of this package are vulnerable to Improper Authorization as it allows users with the normal role/level privileges to interact with the plugin setting, which allows them to take action such as switching on/off any installed plugins which are supposedly accessible by the Administrator only.

PoC:

  1. log in as a normal user.

  2. Browse to http://{HOST}/plugin/settings

  3. We can switch on/off any installed plugins and interact with the setting such as creating and managing maps for the Weathermap plugin.