SQL Injection Affecting librenms/librenms package, versions <1.53


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High

    Threat Intelligence

    EPSS 0.08% (33rd percentile)
Expand this section
NVD
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-LIBRENMSLIBRENMS-466429
  • published 9 Sep 2019
  • disclosed 9 Sep 2019
  • credit Eldar Marcussen

How to fix?

Upgrade librenms/librenms to version 1.53 or higher.

Overview

librenms/librenms is a fully featured network monitoring system that provides a wealth of features and device support.

Affected versions of this package are vulnerable to SQL Injection. Multiple areas within LibreNMS is vulnerable to SQL Injection. This includes:

  • The term parameter is used insecurely in a database query for showing columns of a table within ajax_rulesuggest.php and ajax_search.php
  • Multiple parameters used by graph.php which are sufficiently parameterized

NOTE: This vulnerability has also been identified as: CVE-2019-10671