Command Injection Affecting librenms/librenms package, versions <1.50.1


0.0
high

Snyk CVSS

    Attack Complexity Low
    Privileges Required High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    Exploit Maturity Mature
    EPSS 87.47% (99th percentile)
Expand this section
NVD
7.2 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-LIBRENMSLIBRENMS-466431
  • published 9 Sep 2019
  • disclosed 9 Sep 2019
  • credit Eldar Marcussen

How to fix?

Upgrade librenms/librenms to version 1.50.1 or higher.

Overview

librenms/librenms is a fully featured network monitoring system that provides a wealth of features and device support.

Affected versions of this package are vulnerable to Command Injection. It is possible to inject arbitrary commands in html/includes/graphs/device/collectd.inc.php where user supplied parameters are filtered with the mysqli_escape_real_string function. This function is not the appropriate function to sanitize command arguments as it does not escape a number of command line syntax characters such as backticks, allowing an attacker to inject commands into the variable $rrd_cmd, which gets executed via passthru().