SQL Injection Affecting librenms/librenms package, versions <1.65.1


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.1% (40th percentile)
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-LIBRENMSLIBRENMS-589931
  • published 22 Jul 2020
  • disclosed 22 Jul 2020
  • credit Loginsoft

How to fix?

Upgrade librenms/librenms to version 1.65.1 or higher.

Overview

librenms/librenms is a fully featured network monitoring system that provides a wealth of features and device support.

Affected versions of this package are vulnerable to SQL Injection. An authenticated attacker can achieve SQL Injection via the customoid.inc.php device_id POST parameter to ajax_form.php.