SQL Injection Affecting liftkit/database package, versions <2.13.2


0.0
medium
0
10

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.14% (50th percentile)
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-LIFTKITDATABASE-3231515
  • published 16 Jan 2023
  • disclosed 16 Jan 2023
  • credit Unknown

How to fix?

Upgrade liftkit/database to version 2.13.2 or higher.

Overview

Affected versions of this package are vulnerable to SQL Injection via the function processOrderBy of the file src/Query/Query.php by manipulating the direction argument.