Access Restriction Bypass Affecting lightsaml/lightsaml package, versions <1.3.5


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.22% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Access Restriction Bypass vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-PHP-LIGHTSAMLLIGHTSAML-72139
  • published26 Apr 2018
  • disclosed18 Apr 2018
  • creditUnknown

Introduced: 18 Apr 2018

CVE-2018-1000165  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade lightsaml/lightsaml to version 1.3.5 or higher.

Overview

lightsaml/lightsaml Implements basic SAML 2.0 data model classes, serialization/deserialization to/from xml with XML security and certificates support, and message encapsulations to bindings.

Affected versions of this package are vulnerable to Access Restriction Bypass via the src/LightSaml/Model/XmlDSig/ method. It can result in impersonation of any user from Identity Provider.

References

CVSS Base Scores

version 3.1