SQL Injection Affecting limesurvey/limesurvey package, versions <3.19.0 >=4.0.0, <4.0.0-RC4


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-LIMESURVEYLIMESURVEY-1074897

  • published

    14 Feb 2021

  • disclosed

    14 Feb 2021

  • credit

    Unknown

How to fix?

Upgrade limesurvey/limesurvey to version 3.19.0, 4.0.0-RC4 or higher.

Overview

limesurvey/limesurvey is a FOSS online survey tool on the web.

Affected versions of this package are vulnerable to SQL Injection via the search functionality in the participant model.