Command Injection Affecting mikehaertl/php-shellcommand package, versions <1.6.1


0.0
high
0
10

Snyk CVSS

    Attack Complexity Low
    Confidentiality High

    Threat Intelligence

    EPSS 0.47% (76th percentile)
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-MIKEHAERTLPHPSHELLCOMMAND-538426
  • published 20 Dec 2019
  • disclosed 20 Dec 2019
  • credit Snyk Security Team

How to fix?

Upgrade mikehaertl/php-shellcommand to version 1.6.1 or higher.

Overview

mikehaertl/php-shellcommand is an object oriented interface to shell commands

Affected versions of this package are vulnerable to Command Injection. User input is concatenated with a command within addArg() that will be executed without any check.