SQL Injection Affecting mongodb/mongodb package, versions >=1.1.0, <1.21.5>=2.0.0, <2.4.2


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.33% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about SQL Injection vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-PHP-MONGODBMONGODB-21204076
  • published18 Oct 2026
  • disclosed5 Oct 2026
  • creditUnknown

Introduced: 5 Oct 2026

NewCVE-2026-88023  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade mongodb/mongodb to version 1.21.5, 2.4.2 or higher.

Overview

Affected versions of this package are vulnerable to SQL Injection in the GridFS component due to improper neutralization of special elements in query logic. An attacker can access file content beyond the intended target, delete all file chunks in a bucket, or rename unintended files by injecting structured file identifiers.

CVSS Base Scores

version 4.0
version 3.1