Sensitive Data Exposure Affecting moodle/moodle package, versions >=3.7.0, <3.7.9 >=3.8.0, <3.8.6 >=3.9.0, <3.9.3


0.0
medium
0
10

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.16% (53rd percentile)
Expand this section
NVD
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-MOODLEMOODLE-1042271
  • published 20 Nov 2020
  • disclosed 20 Nov 2020
  • credit A. Schenkel

How to fix?

Upgrade moodle/moodle to version 3.7.9, 3.8.6, 3.9.3 or higher.

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Sensitive Data Exposure. The participants table download in Moodle always included user emails, but should have only done so when users' emails are not hidden.