Improper Authentication Affecting moodle/moodle package, versions >=3.9, <3.9.13 >=3.10, <3.10.10 >=3.11, <3.11.6 >=4.0.0-rc1, <4.0.0
Do your applications use this vulnerable package?
In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.Test your applications
- Snyk ID SNYK-PHP-MOODLEMOODLE-2806344
- published 1 May 2022
- disclosed 1 May 2022
- credit Unknown
How to fix?
moodle/moodle to version 3.9.13, 3.10.10, 3.11.6, 4.0.0 or higher.
moodle/moodle is a learning platform.
Affected versions of this package are vulnerable to Improper Authentication which can allow users with the
moodle/site:uploadusers capability to delete users, without having the necessary