SQL Injection Affecting moodle/moodle Open this link in a new tab package, versions <3.9.14 >=3.10, <3.10.11 >=3.11, <3.11.7 >=4.0, <4.0.1


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-MOODLEMOODLE-2838879

  • published

    19 May 2022

  • disclosed

    19 May 2022

  • credit

    Michael Dunstan

How to fix?

Upgrade moodle/moodle to version 3.9.14, 3.10.11, 3.11.7, 4.0.1 or higher.

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to SQL Injection in Badges code relating to configuring criteria.

Note: in versions 4.0, 3.11.6, 3.10.10 and 3.9.13, access to this vulnerability was available to site administrators only. In earlier versions, access to the relevant capability was also limited to teachers and managers by default.