Incorrect Calculation Affecting moodle/moodle Open this link in a new tab package, versions <3.9.14 >=3.10, <3.10.11 >=3.11, <3.11.7 >=4.0, <4.0.1


0.0
high
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-MOODLEMOODLE-2838881

  • published

    19 May 2022

  • disclosed

    19 May 2022

  • credit

    Shamim Rezaie

How to fix?

Upgrade moodle/moodle to version 3.9.14, 3.10.11, 3.11.7, 4.0.1 or higher.

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Incorrect Calculation where logic, which is used to count, fails login attempts. It can result in the account lockout threshold being bypassed.