Improper Input Validation Affecting moodle/moodle package, versions <3.9.15 >=3.10.0-beta, <3.11.8 >=4.0.0-beta, <4.0.2


0.0
medium
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • Privileges Required

    High

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-MOODLEMOODLE-2969813

  • published

    4 Aug 2022

  • disclosed

    3 Aug 2022

  • credit

    Unknown

How to fix?

Upgrade moodle/moodle to version 3.9.15, 3.11.8, 4.0.2 or higher.

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Improper Input Validation in the readdata() function in question/format/blackboard_six/format.php, which allows a "teacher", "manage"r, or admin user to read arbitrary files.