SQL Injection Affecting phpmyfaq/phpmyfaq package, versions <4.1.9


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.34% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about SQL Injection vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-PHP-PHPMYFAQPHPMYFAQ-21717182
  • published26 Oct 2026
  • disclosed12 Oct 2026
  • creditDaniel Coles

Introduced: 12 Oct 2026

NewCVE-2026-109573  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade phpmyfaq/phpmyfaq to version 4.1.9 or higher.

Overview

phpmyfaq/phpmyfaq is a FAQ system for PHP and MySQL, PostgreSQL and other databases

Affected versions of this package are vulnerable to SQL Injection via the escape method in PdoMysql.php, which uses backslash escaping (\') that is rendered ineffective when the MySQL/MariaDB server operates under the NO_BACKSLASH_ESCAPES SQL mode. Under that mode, a single quote in user-supplied input is not neutralised, allowing an attacker to break out of the string literal and inject arbitrary SQL.

Note: This is only exploitable when the MySQL/MariaDB server is configured with the NO_BACKSLASH_ESCAPES SQL mode, which is a non-default but documented setting enabled by some managed database services and recommended by security hardening guides such as the CIS MySQL Benchmark.

References

CVSS Base Scores

version 4.0
version 3.1