Authorization Bypass Through User-Controlled Key Affecting phpmyfaq/phpmyfaq package, versions >=4.0.0, <4.1.9>=4.2.0-alpha, <4.2.0-beta


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.37% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Authorization Bypass Through User-Controlled Key vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-PHP-PHPMYFAQPHPMYFAQ-21717189
  • published26 Oct 2026
  • disclosed17 Oct 2026
  • creditNijat Sultanov

Introduced: 17 Oct 2026

NewCVE-2026-111908  (opens in a new tab)
CWE-639  (opens in a new tab)

How to fix?

Upgrade phpmyfaq/phpmyfaq to version 4.1.9, 4.2.0-beta or higher.

Overview

phpmyfaq/phpmyfaq is a FAQ system for PHP and MySQL, PostgreSQL and other databases

Affected versions of this package are vulnerable to Authorization Bypass Through User-Controlled Key via the update method in FaqController.php, where the REST API FAQ update endpoint enforces only a global "edit FAQ" right without performing object-level authorization. An authenticated attacker can supply any valid FAQ ID to overwrite restricted, inactive, pending, or otherwise access-controlled FAQ records they are not permitted to modify.

References

CVSS Base Scores

version 4.0
version 3.1