Cross-site Request Forgery (CSRF) Affecting phpmyfaq/phpmyfaq package, versions >=4.0.0, <4.1.9


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.12% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-PHPMYFAQPHPMYFAQ-21717196
  • published26 Oct 2026
  • disclosed17 Oct 2026
  • creditNijat Sultanov

Introduced: 17 Oct 2026

NewCVE-2026-111907  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade phpmyfaq/phpmyfaq to version 4.1.9 or higher.

Overview

phpmyfaq/phpmyfaq is a FAQ system for PHP and MySQL, PostgreSQL and other databases

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) via the POST /admin/api/update-database endpoint, which executes database migrations without validating a CSRF token. The updateDatabase() function omits the Token::verifyToken() call that other update-related endpoints use, so an attacker can lure a logged-in user into submitting a cross-site request that triggers database migrations, potentially impacting database integrity or availability.

Note: This is only exploitable against users who hold the CONFIGURATION_EDIT permission.

References

CVSS Base Scores

version 4.0
version 3.1