Use of Single-factor Authentication Affecting phpmyfaq/phpmyfaq package, versions <4.1.9>=4.2.0-alpha, <4.2.0-beta


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.35% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-PHPMYFAQPHPMYFAQ-21717198
  • published26 Oct 2026
  • disclosed17 Oct 2026
  • creditHama1cco

Introduced: 17 Oct 2026

NewCVE-2026-111884  (opens in a new tab)
CWE-308  (opens in a new tab)

How to fix?

Upgrade phpmyfaq/phpmyfaq to version 4.1.9, 4.2.0-beta or higher.

Overview

phpmyfaq/phpmyfaq is a FAQ system for PHP and MySQL, PostgreSQL and other databases

Affected versions of this package are vulnerable to Use of Single-factor Authentication via UserController::updateData (api/user/data/update), which does not require the current password when changing an account e-mail address, checking only the session and CSRF token. An attacker with a hijacked session can replace the victim's registered e-mail with their own address, then trigger phpMyFAQ's anonymous password-reset flow, which delivers a signed reset link to the attacker's mailbox. Consuming that link sets a new password the attacker controls, completing a full account takeover for non-2FA accounts, including superadmin.

Note: This is only exploitable when the attacker has already obtained a valid session for the target account.

References

CVSS Base Scores

version 4.0
version 3.1