Improper Privilege Management Affecting phpmyfaq/phpmyfaq package, versions >=4.2.0-alpha.2, <4.2.0-beta


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.28% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Improper Privilege Management vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-PHP-PHPMYFAQPHPMYFAQ-21717204
  • published26 Oct 2026
  • disclosed17 Oct 2026
  • creditzx

Introduced: 17 Oct 2026

NewCVE-2026-111890  (opens in a new tab)
CWE-269  (opens in a new tab)

How to fix?

Upgrade phpmyfaq/phpmyfaq to version 4.2.0-beta or higher.

Overview

phpmyfaq/phpmyfaq is a FAQ system for PHP and MySQL, PostgreSQL and other databases

Affected versions of this package are vulnerable to Improper Privilege Management via the updateUserRights method in UserController.php, where a non-SuperAdmin administrator with the USER_EDIT right can widen their own language-scoped permissions by re-saving the rights they already hold. When user rights are re-saved, the existing per-right language restriction rows are dropped by refuseAllUserRights() before being re-granted, and the code previously failed to re-apply the acting user's own language scope as a ceiling. This allows a language-restricted administrator to escalate their privileges to a broader language scope than originally granted.

References

CVSS Base Scores

version 4.0
version 3.1