Improper Authentication Affecting phpmyfaq/phpmyfaq package, versions >=4.2.0-alpha, <4.2.0-beta


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.44% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Improper Authentication vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-PHP-PHPMYFAQPHPMYFAQ-21717206
  • published26 Oct 2026
  • disclosed17 Oct 2026
  • creditbp0lr

Introduced: 17 Oct 2026

NewCVE-2026-111898  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade phpmyfaq/phpmyfaq to version 4.2.0-beta or higher.

Overview

phpmyfaq/phpmyfaq is a FAQ system for PHP and MySQL, PostgreSQL and other databases

Affected versions of this package are vulnerable to Improper Authentication via resolveLocalLogin in the Keycloak authentication flow, where an existing local account can be resolved by matching the preferred_username or email claim from a Keycloak token rather than requiring a stored Keycloak subject (sub) link. An attacker who controls a Keycloak identity with a preferred_username or email claim that collides with an existing local account can authenticate as that local account without ever having proved ownership of it, effectively taking over the account.

References

CVSS Base Scores

version 4.0
version 3.1