Incorrect Authorization Affecting phpoffice/phpspreadsheet package, versions >=4.0.0, <5.10.0>=3.3.0, <3.10.8>=2.2.0, <2.4.8>=2.0.0, <2.1.19<1.30.7


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.34% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-PHP-PHPOFFICEPHPSPREADSHEET-21700351
  • published25 Oct 2026
  • disclosed22 Oct 2026
  • creditzx (Jace)

Introduced: 22 Oct 2026

NewCVE-2026-108360  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade phpoffice/phpspreadsheet to version 5.10.0, 3.10.8, 2.4.8, 2.1.19, 1.30.7 or higher.

Overview

phpoffice/phpspreadsheet is a Spreadsheet engine that Read, Create and Write Spreadsheet documents in PHP .

Affected versions of this package are vulnerable to Incorrect Authorization via the ODS file reader in src/PhpSpreadsheet/Reader/Ods.php and the XML scanner in src/PhpSpreadsheet/Reader/Security/XmlScanner.php, where an attacker can supply a malicious ODS document containing an external entity reference to cause the server to disclose internal files or make server-side requests. The patch also hardens table:number-rows-repeated and table:number-columns-repeated attribute handling to prevent integer overflow-based resource exhaustion when parsing ODS files.

CVSS Base Scores

version 4.0
version 3.1