SQL Injection Affecting pimcore/pimcore package, versions <10.3.6


0.0
medium

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
    Privileges Required High
    Confidentiality High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-PIMCOREPIMCORE-2774702
  • published 24 Apr 2022
  • disclosed 24 Apr 2022
  • credit mylong

How to fix?

Upgrade pimcore/pimcore to version 10.3.6 or higher.

Overview

pimcore/pimcore is a content & product management framework (CMS/PIM/E-Commerce).

Affected versions of this package are vulnerable to SQL Injection in GridHelperService.php, which is exploitable via the following APIs:

  1. /grid-proxy

  2. /get-export-jobs

  3. /get-batch-jobs