Cross-site Request Forgery (CSRF) Affecting pimcore/pimcore package, versions <5.3.0


0.0
high

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-PIMCOREPIMCORE-72271
  • published 19 Aug 2018
  • disclosed 17 Aug 2018
  • credit Unknown

How to fix?

Upgrade pimcore/pimcore to version 5.3.0 or higher.

Overview

pimcore/pimcore is a Content & Product Management Framework (CMS/PIM/E-Commerce).

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). An attacker could conduct the attack by leveraging the validation of the X-pimcore-csrf-token anti-CSRF token.