Cross-site Request Forgery (CSRF) Affecting shopware/shopware Open this link in a new tab package, versions >=5.2.0, <5.7.9


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-SHOPWARESHOPWARE-2805812

  • published

    29 Apr 2022

  • disclosed

    28 Apr 2022

  • credit

    Michael Grothe

How to fix?

Upgrade shopware/shopware to version 5.7.9 or higher.

Overview

shopware/shopware is an open source e-commerce software made in Germany

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) by tokens that are not renewed after login and logout.