Insufficient Session Expiration Affecting silverstripe/hybridsessions package, versions <2.4.1>=2.5.0, <2.5.1


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.9% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-SILVERSTRIPEHYBRIDSESSIONS-2936267
  • published28 Jun 2022
  • disclosed28 Jun 2022
  • creditKartik Patel

Introduced: 28 Jun 2022

CVE-2022-24444  (opens in a new tab)
CWE-613  (opens in a new tab)

How to fix?

Upgrade silverstripe/hybridsessions to version 2.4.1, 2.5.1 or higher.

Overview

Affected versions of this package are vulnerable to Insufficient Session Expiration when using the hybridsessions module without the session-manager module installed. The session IDs are saved to the disk and users can still use them to make authenticated requests.

CVSS Base Scores

version 3.1