SQL Injection Affecting silverstripe/registry package, versions >=2.1.0, <2.1.1>=2.2.0, <2.2.1


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.36% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about SQL Injection vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-PHP-SILVERSTRIPEREGISTRY-449610
  • published11 Jun 2019
  • disclosed11 Jun 2019
  • creditTim Oliver

Introduced: 11 Jun 2019

CVE-2019-12149  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade silverstripe/registry to version 2.1.1, 2.2.1 or higher.

Overview

silverstripe/registry is an add on module for an open source content management system (CMS) that provids search and export interfaces for datasets.

Affected versions of this package are vulnerable to SQL Injection which may allow specially crafted user input to be executed as SQL statements.

CVSS Base Scores

version 3.1