Cross-site Request Forgery (CSRF) Affecting snipe/snipe-it package, versions <5.3.0


0.0
medium

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
    User Interaction Required
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-SNIPESNIPEIT-1759511
  • published 19 Oct 2021
  • disclosed 19 Oct 2021
  • credit amammad

How to fix?

Upgrade snipe/snipe-it to version 5.3.0 or higher.

Overview

snipe/snipe-it is an asset management system built on Laravel.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) where someone could trick a logged in user into restoring an asset.