Cross-site Request Forgery (CSRF) Affecting snipe/snipe-it package, versions >=0.0.0, <v5.3.2


0.0
medium

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
    User Interaction Required
Expand this section
NVD
4.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-SNIPESNIPEIT-1920921
  • published 14 Nov 2021
  • disclosed 14 Nov 2021
  • credit haxaton

How to fix?

Upgrade snipe/snipe-it to version v5.3.2 or higher.

Overview

snipe/snipe-it is an asset management system built on Laravel.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) via custom field settings, which can potentially cause an admin user to unintentionally modify custom forms.

References