Server-side Request Forgery (SSRF) Affecting snipe/snipe-it package, versions <6.0.0-RC-1


0.0
low

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
    Privileges Required High
Expand this section
NVD
7.2 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-SNIPESNIPEIT-2310018
  • published 7 Dec 2021
  • disclosed 7 Dec 2021
  • credit haxatron

How to fix?

Upgrade snipe/snipe-it to version 6.0.0-RC-1 or higher.

Overview

snipe/snipe-it is an asset management system built on Laravel.

Affected versions of this package are vulnerable to Server-side Request Forgery (SSRF) via the Slack integration. Admin users on the external network can perform blind POST-based SSRF.

References