Access Restriction Bypass Affecting snipe/snipe-it package, versions >=0.0.0, <v5.3.4


0.0
medium

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
Expand this section
NVD
4.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-SNIPESNIPEIT-2316751
  • published 12 Dec 2021
  • disclosed 12 Dec 2021
  • credit haxaton

How to fix?

Upgrade snipe/snipe-it to version v5.3.4 or higher.

Overview

snipe/snipe-it is an asset management system built on Laravel.

Affected versions of this package are vulnerable to Access Restriction Bypass via the /models/{id}/clone endpoint. This allows users without view asset model permissions to view asset models.

References