Cross-site Request Forgery (CSRF) Affecting snipe/snipe-it package, versions >=0.0.0, <v5.3.6


0.0
medium

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
    User Interaction Required
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-SNIPESNIPEIT-2321961
  • published 19 Dec 2021
  • disclosed 19 Dec 2021
  • credit haxatron

How to fix?

Upgrade snipe/snipe-it to version v5.3.6 or higher.

Overview

snipe/snipe-it is an asset management system built on Laravel.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). Unauthenticated attackers can disrupt request tracking by sending malicious HTML to a user which will cause them to request an asset.

References