Improper Access Control Affecting snipe/snipe-it package, versions <5.3.7


0.0
medium

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
Expand this section
NVD
5.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-SNIPESNIPEIT-2336166
  • published 12 Jan 2022
  • disclosed 12 Jan 2022
  • credit Unknown

How to fix?

Upgrade snipe/snipe-it to version 5.3.7 or higher.

Overview

snipe/snipe-it is an asset management system built on Laravel.

Affected versions of this package are vulnerable to Improper Access Control via bulk actions (bulk-edit / bulk-delete / form info) in asset models. This is due to missing access control checks.

References