Improper Access Control Affecting snipe/snipe-it package, versions <6.0.0-RC-1


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
5.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-SNIPESNIPEIT-2340606
  • published 14 Jan 2022
  • disclosed 14 Jan 2022
  • credit starkitsec

How to fix?

Upgrade snipe/snipe-it to version 6.0.0-RC-1 or higher.

Overview

snipe/snipe-it is an asset management system built on Laravel.

Affected versions of this package are vulnerable to Improper Access Control. A user with no rights for API tokens can view the page where API tokens can be generated and can generate API tokens.

PoC:

Create a user with no permission for anything (i.e. everything on deny).

Log in with this user to the web application.

Visit http://127.0.0.1:8000/account/api => The user can see and generate personal API tokens even the user has no rights for it.